请选择 进入手机版 | 继续访问电脑版

1621 新版 hmcode

固件 固件 4323 人阅读 | 46 人回复 | 2021-04-21

本帖最后由 zytc 于 2021-4-21 11:45 编辑

请问这个1621平台新版的hmcode支持虚拟化吗?能不能上传一下

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

回答|共 46 个

TecSupport

发表于 2021-4-21 13:50:28 | 显示全部楼层

您好,附件同步了,感谢反馈
回复

使用道具 举报

zytc

发表于 2021-4-21 15:05:08 | 显示全部楼层

我们现在用的固件版本如图

烧写了新版本的hmcode,系统无法启动了,rpc 读到的是 core  0: 0x1fdf8

请问,这个还需要配合其它固件吗,有没有完整的4M flash文件可以提供呢?

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

changk

发表于 2021-4-21 16:02:31 | 显示全部楼层

您好,您看说明,新版的hmcode只支持申威1621机器,不知道您是否把它烧写到申威3231机器中了
回复

使用道具 举报

zytc

发表于 2021-4-21 16:11:17 | 显示全部楼层

changk 发表于 2021-4-21 16:02
您好,您看说明,新版的hmcode只支持申威1621机器,不知道您是否把它烧写到申威3231机器中了
...

是 1621 服务器
回复

使用道具 举报

TecSupport

发表于 2021-4-21 17:06:04 | 显示全部楼层

zytc 发表于 2021-4-21 15:05
我们现在用的固件版本如图

烧写了新版本的hmcode,系统无法启动了,rpc 读到的是 core  0: 0x1fdf8

您可以用维护看一下:
rflash -o bmc:0:0:0 -a 0x0 -l 0x100 -b

检查一下是不是把srom冲掉了
回复

使用道具 举报

zytc

发表于 2021-4-21 17:18:54 | 显示全部楼层

本帖最后由 zytc 于 2021-4-21 17:35 编辑

应该没有把srom冲掉,我把原来的hmcode烧进去后,就又能启动了.

另外我使用能启动操作系统的环境,只替换 sw6a-4level.zip 里的grub.efi , BIOS滚动条后出现一个固定的光标,没有正确显示grub菜单。


rpc 显示 core  0: 0x18778


lazyrrk 查看 BIOS 已加载完毕 “Via Boot Option: \boot\grub\grub.efi Found”


是编译器版本的问题吗? BIOS 是4.5.3 编译器编译的,这个 grub.efi 是哪个版本编译器编译出来的呢?




回复

使用道具 举报

TecSupport

发表于 2021-4-21 17:22:39 | 显示全部楼层

TecSupport 发表于 2021-4-21 17:06
您可以用维护看一下:
rflash -o bmc:0:0:0 -a 0x0 -l 0x100 -b

另外,再确认一下,你当前系统的内核是用的社区-助力申威-开源项目中发布版本的内核源码去编译的吗?发布版本的内核源码中,有一个是6A的配置文件,要用那个版本内核源码编译生成的内核模块启动系统哦~

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

zytc

发表于 2021-4-21 17:37:15 | 显示全部楼层

本帖最后由 zytc 于 2021-4-21 18:01 编辑

也就是说发布的内核也支持1621启动了?

我用的是UOS的内核以及配置文件

另外我使用能启动操作系统的环境,只替换 sw6a-4level.zip 里的grub.efi , BIOS滚动条后出现一个固定的光标,没有正确显示grub菜单。
rpc 显示 core  0: 0x18778
lazyrrk 查看 BIOS 已加载完毕 “Via Boot Option: \boot\grub\grub.efi Found”

然后我又试了下 sw6a-3level.zip,grub 菜单也是不能正常加载




是编译器版本的问题吗? BIOS 是4.5.3 编译器编译的,这个 grub.efi 是哪个版本编译器编译出来的呢?

回复

使用道具 举报

TecSupport

发表于 2021-4-22 08:56:31 | 显示全部楼层

zytc 发表于 2021-4-21 17:37
也就是说发布的内核也支持1621启动了?

我用的是UOS的内核以及配置文件

您好,问题答复如下:
1.发布的内核源码3231支持1621了,这个需要使用对应平台的hmcode;如,你现在使用1621配置文件编译了内核,那么hmcode也应该是对应的1621(6A)版本;
2. grub.efi是和bios配套使用的,如,你现在使用的是非同源内核bios,那么grub.efi也应该用对应的;

如果你的服务器已经启动并正常开启进入操作系统,grub.efi和你的编译器没有关系的
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则